Aegir Discussions

Syndicate content
Updated: 6 min 5 sec ago

How to deploy configuration level changes on multiple sites?

36 min 2 sec ago
pI have multiple sites in Aegir. All sites are identical. So when a new feature added or old issue fixed then I have to deploy the change individually for each site. I am not talking about codebase changes as all sites are using same codebase. But the problem with the configuration level changes./p pstrongIs there any automatic to deploy configuration level changes without visit every site individually?/strong/p

Link to @mig5's article on Fabric and drush provision

Sun, 11/02/2014 - 11:47
pIn mig5's excellent a href=http://community.aegirproject.org/content/manage-your-aegir-system-command-linearticle on using provision from the command line/a there's a link to an article on using it in conjunction with Fabric etc. ... which is broken. Any chance you could re-link the article?/p pMany thanks!/p

How to have a custom site provision websites ?

Tue, 10/28/2014 - 20:14
pHello,/p pI'm hosting my sites at omega8 and I've been provisioning them through the regular hostmaster site./p pI now would like to use a custom website in order to provision and manage my websites (create, edit, delete, flush cache, disable, add/edit/delete aliases etc...)./p pI've been in touch with omega8 support team and they told me all of what could be told over support mails, I guess now my questions are getting out of the scope of support requests and since I can't find much documentation on precisely what I want to do I'm asking it here: What is the architecture I should put in place/ppa href=http://community.aegirproject.org/discuss/how-have-custom-site-provision-websites target=_blankread more/a/p

Virtual mailboxes for additional clients on same domain set up with BOA

Tue, 10/28/2014 - 11:46
pI have installed BOA. It looks very nice. I used Virtualmin before and heard so many great things about BOA I tried it. My question is that creating virtual servers (domains) in Virtualmin is very easy and one domain can have as many user mailboxes as needed. How to do the same with BOA? How to connect to the BOA mail server from an external email client? What are the SMTP/POP3/IMAP configuration? If no similar mail services, what would be the best solution? Can Virtualmin run alongside BOA? I installed _EXTRA_LIST with VMN (Webmin)./ppa href=http://community.aegirproject.org/discuss/virtual-mailboxes-additional-clients-same-domain-set-boa target=_blankread more/a/p

Warning on clone or migration - standard profile missing

Sun, 10/19/2014 - 10:47
pWhen I try to clone or migrate my side, there is a warning that the standard profile is missing./p pStrangely enough, there are two entries in the row - one time it is ticked of and one time it is declared as missing./p pCloning or migrating still works well and no problems appear afterwards./p

3.0-alpha1 released

Mon, 09/22/2014 - 13:06
div class=field field-type-nodereference field-field-referenced-book-page div class=field-items div class=field-item odd div class=field-label-inline-first Referenced Page:nbsp;/div a href=/3.0-alpha13.0-alpha1 release notes/a /div /div /div

Installing the Hosting Queue Daemon on Arch Linux

Wed, 08/20/2014 - 11:18
pI know this might be a little off topic. I have installed Aegir on Arch Linux and I had no issues with the installation. Everything works except the tasks are not executed. They refresh every 20Seconds as I have set it up, however they are not executed. I beleive this is because the Hosting queue daemon is not running./ppa href=http://community.aegirproject.org/discuss/installing-hosting-queue-daemon-arch-linux target=_blankread more/a/p

Backup and deploy on a new server Creating default object from empty value warning, can't verify.

Tue, 08/19/2014 - 22:22
pI'm moving my sites to a new server. - I have a fresh Aegir 2.1 (with nginx) - I've moved old d7 platform (without sites) from an Aegir 1.9 setup to the 2.1, verified the it and can create new sites on it. - I've created a backup in aegir on the old server and transferred it across, and I'm using provision deploy to restore the backup to the moved platform. You know the drill. - Provision save and deploy on a site appear to work without a hitch./ppa href=http://community.aegirproject.org/discuss/backup-and-deploy-new-server-creating-default-object-empty-value-warning-cant-verify target=_blankread more/a/p

.htaccess password and IP protection doesn't work with Aegir

Fri, 08/15/2014 - 20:02
pHi, the idea is to protect access to website with password if visitor is not coming from local IP (192.168.1.xxx). So I tried on Quickstart (doesn't have Aegir, Drush only) to set following in .htaccess: div class=codeblockcodeAuthName quot;Username and password requiredquot;br /nbsp; AuthUserFile /home/quickstart/websites/mytestsite/.htpasswdbr /nbsp; AuthType Basicbr /nbsp; Require valid-userbr /nbsp; Order Deny,Allowbr /nbsp; Deny from allbr /nbsp; Allow from 192.168.1.br /nbsp; Satisfy Any/code/div And this works. Now I tried to add this in .htaccess in platform root on server where Aegir is installed but it didn't work./ppa href=http://community.aegirproject.org/discuss/htaccess-password-and-ip-protection-doesnt-work-aegir target=_blankread more/a/p

Hosting front end offline after upgrade - database gone

Tue, 08/12/2014 - 22:04
pI ran some system updates a while back which took my sites offline. After much effort, I upgraded aegir to 2.1 (as well as a number of other things) and got the sites back online. The web front end was still offline though, but I figured I'd solve that later. Well, later is now, and while trying to figure out why it's offline, I discovered that the aegir database is gone! No wonder the site won't load./p pNot sure where to start./ppa href=http://community.aegirproject.org/discuss/hosting-front-end-offline-after-upgrade-database-gone target=_blankread more/a/p